Payroll reports not downloading from dashboard

Incident Report for Sparrow

Resolved

The issue has been resolved.
Posted May 11, 2026 - 23:04 UTC

Identified

We've received reports of customers not being able to download payroll reports from the dashboard. Our team is currently working on an immediate fix.
Posted May 11, 2026 - 21:23 UTC
This incident affected: Sparrow Platform.